Windows Updates - Need assistance with forcing them

Junglist0682

Members
Members
Hi all,

Yesterday I began working on updating Surface PRO's, however every attempt I made an updating them they failed. I'm a bit curious if anyone here has any solutions to force update?

Your device is missing important security and quality fixes. We couldn't connect to the update service. We'll try again later, or you can check now. If it still doesn't work, make sure you're connected to the Internet.

Thanks in advance
 

nodle

Cheesemonger
Administrator
I use to know how to do this better. I know in the built in Windows troubleshooter there is something to run. Basically you need to clear the cache or repair the corrupt file. But before we start is your time and date correct? Windows updates won't work if these are off and being new Surface Pros it's making me wonder if they defaulted to the wrong time zone? I use to have some bat script tools that would clear the cache for you, but here is a walk though.

https://www.intowindows.com/how-to-clear-windows-update-cache-in-windows-10/

Also I used another tool for it but I can't remember it at the moment but will try to remember, in the meantime try above.
 

Junglist0682

Members
Members
hi nodle - the time was correct when I was working on them - a few steps I tried are below

Restarted windows update via services as ADMIN (same outcome)
downloaded WSUS (failed)
Switched accounts - same outcome
Tried WSUS once more - same outcome
Tried > https://support.microsoft.com/en-us/help/4023506/surface-trouble-installing-surface-updates (same outcome) - not able to download updates
Removed from domain for further troubleshooting (same outcome)
Ran Windows Update troubleshooter (no luck)
Added Google DNS for testing via advance and moved them up to 1st and 2nd
tried WSUS once more with Google DNS (still no luck)
Tried > https://www.thewindowsclub.com/repair-fix-windows-updates-with-fix-wu-utility (still no luck)

After what i am seeing I am beginning to think something is set in place that isn't allowing connection with MS
I may need to get with out network team and find out what could be causing this - Maybe ACL?

I will still try what you have provided - thank you for the reply
 

nodle

Cheesemonger
Administrator
Sorry for not getting back sooner, was gone most of the day yesterday. Might want to check your firewall. It's quite a coincidence that they are all having the same problem. Something like this once happened at my old job where it for some reason Microsoft's IP range were blacklisted in our firewall. I fought with it for almost a week and kept asking the guy to check in but sure enough after he did he came downstairs laughing about it. Still trying to think of that other tool that worked well, I can see the icon for it was a red toolbox. I'll try to remember.
 

Junglist0682

Members
Members
Thanks for the reply nodle - spoke with our network guy and the current WiFi network the employees are on prevents updates so I am going to switch to another WiFi network and retry
 

Junglist0682

Members
Members
looks like they are now downloading - i had to whitelist the devices via the meraki portal and i am currently working on updating them as type this
 

Junglist0682

Members
Members
customer is x amount of hours away from where I am, however one of our escalations guy contacted me and we spent some time reviewing. Turns out a rule was in place to deny updates so we ended up adding a rule to allow via IP on two networks via layer 3 policy which allowed it to kick in.

I did more updates today. What a pain
I had a feeling it was network related I am just not familiar with the meraki portal as much as I would like to be or with the site in general
 

nodle

Cheesemonger
Administrator
I am just not familiar with the meraki portal
Don't feel bad, my old company used it and I thought it was a joke. You don't pay your subscription you get locked out. There are a lot better WiFI devices out there these days like Ubiquiti etc.
 
Top